Sps Special Services Links

Special Education Forms

 New:  Special Education Procedural Safeguard Notice

Adobe Reader

ProgressBook v17.0.0 End User Requirement

The following table lists the supported software versions for ProgressBook end users.  The ProgressBoiok Suite has been tested successfully using these product and version configurations.  other configurations may function without issue; however, these are the versions actively tested and supported in the ProgressBook Suite for Release 17.0.0

Windows Operating System Recommended Browser Adobe Reader
Windows 7 SP 1 Internet Explorer 11 11.0 or later
Windows 7 SP 1 Firefox 53 or later  11.0 or later
Windows 7 SP 1 Google Chrome 58 or later  11.0 or later
Windows 8 & 8.1 Internet Explorer 11  11.0 or later
Windows 8 & 8.1 Firefox 53 or later 11.0 or later
Windows 8 & 8.1 Google Chrome 58 or later 11.0 or later
Windows 10 Internet Explorer 11 11.0 or later
Windows 10 Firefox 53 or later 11.0 or later
Windows 10 Google Chrome 58 or later 11.0 or later

 

MAC Operating System Recommended Browser Adobe Reader
MAC OS X 10.11 "El Capitan"

Safari 10.1

 11.0 or later
MAC OS X 10.12 "Sierra"

 Safari 10.1

11.0 or later

 

 Popup Blockers

The Special Services application displays the PDF documents in a Popup window.  Any Popup blocker must be disabled for the Special Services application to function properly.  Popup blockers vary based on Operating System, Browser version, and third party tools such as the Google bar, etc.  Check your system settings and be sure to enable pop ups for the Special Services Website.

 

Sps Application Use:
The Sps Special Services application uses Adobe Reader for the following features:

  • Print
  • Read Completed Tasks
  • Read, Print and Export IEP Summary Page into PDF
  • Read, Print, and Export Reports in Report Builder into PDF

Please Note:  These are minimum supported versions of Firefox and Google Chrome required by the ProgressBook Suite.  Due to the rapid release cycle of these browsers, the ProgressBook Suite has been tested with these versions.